Author Topic: Mage Guild  (Read 27132 times)

Vanguard

  • Rogueliker
  • ***
  • Posts: 1112
  • Karma: +0/-0
    • View Profile
Mage Guild
« on: June 25, 2008, 03:06:01 PM »
How many of you have tried this game?

http://glistenimages.com/Lukos/lukosMageGuild.htm

It has been mentioned in an earlier post on this site's main page, but I feel it hasn't gotten as much press as it deserves.

It's a pretty good game with a unique levelling system and a focus on tactical and resourceful gameplay over grinding for stat improvement.

Give it a shot sometime!

Edit: fixed the url
« Last Edit: October 29, 2008, 04:36:57 AM by Curseman »

Vanguard

  • Rogueliker
  • ***
  • Posts: 1112
  • Karma: +0/-0
    • View Profile
Re: Mage Guild
« Reply #1 on: July 02, 2008, 11:23:26 PM »
So has no one here tried this then?

It's a really good game, but it hasn't received much publicity.  I'm sure the creator would appreciate any support you could offer.

I'd be happy to answer any questions about the game as well. ;)
« Last Edit: October 29, 2008, 04:37:39 AM by Curseman »

makkE

  • Newcomer
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: Mage Guild
« Reply #2 on: July 09, 2008, 07:47:02 PM »
I just tried running the .exe, but it says (rough translation):

"The application didn´t initialize correctly (0xc0000135)"
"
I´m on winxp.

Nahjor

  • Newcomer
  • Posts: 33
  • Karma: +0/-0
    • View Profile
    • Email
Re: Mage Guild
« Reply #3 on: July 10, 2008, 03:48:00 PM »
Hey, I'm the developer responsible for MageGuild, and thus the fact that it doesn't work. :)

The first thing I'd check is to make sure that your .NET Framework is updated all the way. I'd guess it only needs to be updated to 2.0, but going up to 3.0 can't hurt.

If that checks out, I'd double-check your installation; make sure that the .zip file was fully unpacked, and that everything went where it was supposed to.

If neither of those ideas fixes your problem, I'm not sure where to go next. Any more information you could give me about the error you're getting would be great; I'll keep an eye on this thread, plus you can get ahold of me on MageGuild's forums (http://lukos.forumotion.com/) or at nahjor@gmail.com directly.

Let me know how it turns out!

Anvilfolk

  • Rogueliker
  • ***
  • Posts: 374
  • Karma: +0/-0
    • View Profile
Re: Mage Guild
« Reply #4 on: July 10, 2008, 10:27:54 PM »
I really felt like trying it right now, but unfortunately I couldn't make it work on Linux.

I had some high hopes, since with the "mono" and "libmono-winforms2.0-cil" the main menu actually runs. I see all those nifty ASCII flames and all. It's a tad slow, especially on input, but I can move the menu-selection cursor around. However, whatever the option I chose, I get this baby:

Code: [Select]
$ mono MageGuild.exe
System.NullReferenceException: A null value was found where an object instance was required.
  at System.Windows.Forms.XplatUIX11.PostMessage (IntPtr handle, Msg message, IntPtr wparam, IntPtr lparam) [0x00000]
  at System.Windows.Forms.XplatUI.PostMessage (IntPtr hwnd, Msg message, IntPtr wParam, IntPtr lParam) [0x00000]
  at System.Windows.Forms.X11Keyboard.TranslateMessage (System.Windows.Forms.MSG& msg) [0x00000]
  at System.Windows.Forms.XplatUIX11.TranslateMessage (System.Windows.Forms.MSG& msg) [0x00000]
  at System.Windows.Forms.XplatUIX11.DoEvents () [0x00000]
  at System.Windows.Forms.XplatUI.DoEvents () [0x00000]
  at System.Windows.Forms.Application.DoEvents () [0x00000]
  at MageGuild.menuMain.PopMain (RLLib.RLDisplay RD) [0x00000]
  at MageGuild.frmMain.rlDisplay1_Load (System.Object sender, System.EventArgs e) [0x00000]
  at (wrapper delegate-invoke) System.MulticastDelegate:invoke_void_object_EventArgs (object,System.EventArgs)
  at System.Windows.Forms.UserControl.OnLoad (System.EventArgs e) [0x00000]
  at System.Windows.Forms.UserControl.OnCreateControl () [0x00000]
  at System.Windows.Forms.Control.CreateControl () [0x00000]
  at System.Windows.Forms.Control.WmShowWindow (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.ScrollableControl.WndProc (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.ContainerControl.WndProc (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.UserControl.WndProc (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000]

Unhandled Exception: System.NullReferenceException: A null value was found where an object instance was required.
  at System.Windows.Forms.Control.OnParentBindingContextChanged (System.EventArgs e) [0x00000]
  at System.Windows.Forms.Control.OnBindingContextChanged (System.EventArgs e) [0x00000]
  at System.Windows.Forms.ContainerControl.OnCreateControl () [0x00000]
  at System.Windows.Forms.Form.OnCreateControl () [0x00000]
  at System.Windows.Forms.Control.CreateControl () [0x00000]
  at System.Windows.Forms.Control.SetVisibleCore (Boolean value) [0x00000]
  at System.Windows.Forms.Form.SetVisibleCore (Boolean value) [0x00000]
  at System.Windows.Forms.Control.set_Visible (Boolean value) [0x00000]
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.Control:set_Visible (bool)
  at System.Windows.Forms.Application.RunLoop (Boolean Modal, System.Windows.Forms.ApplicationContext context) [0x00000]
  at System.Windows.Forms.Application.Run (System.Windows.Forms.Form mainForm) [0x00000]
  at MageGuild.Program.Main () [0x00000]


Any clues?
"Get it hot! Hit it harder!!!"
 - The tutor warcry

One of They Who Are Too Busy

Nahjor

  • Newcomer
  • Posts: 33
  • Karma: +0/-0
    • View Profile
    • Email
Re: Mage Guild
« Reply #5 on: July 11, 2008, 02:01:46 AM »
Thanks for giving it a shot. :)

As far as the Mono situation, I know there's a bug with Mono in v0.6.1 (the MG that's released right now), but this one is a little bit different. It works OK under Mono on my machine, but it's a Windows machine, so that's of limited help.

I'll look into it in a little more depth, but I'm trying to focus on getting 0.7 released at the moment; the Mono bug I know about is fixed in that, so when that hits, give it another try. If that doesn't correct your problem, then we'll get down to brass tacks and figure out what's wrong.

I hope to have 0.7 out before too much longer (...yeah, I know, I've said that before...), so keep an eye on the Lukos site/forums, Usenet, etc. I'll try to remember to post here when it hits, too.

Nahjor

  • Newcomer
  • Posts: 33
  • Karma: +0/-0
    • View Profile
    • Email
Re: Mage Guild
« Reply #6 on: July 25, 2008, 07:00:39 PM »
Just thought I'd note that MageGuild 0.7's been released.

Same download site as previously, http://www.glistenimages.com/Lukos/lukosMageGuild.htm. Toss me any bugs or issues you come across on here, via e-mail (nahjor@gmail.com), or on the Lukos forums (http://lukos.forumotion.com).

Thanks!

Brigand

  • Rogueliker
  • ***
  • Posts: 93
  • Karma: +0/-0
    • View Profile
Re: Mage Guild
« Reply #7 on: July 28, 2008, 06:37:48 PM »
Pretty cool little game! I haven't gotten very far, but it has been fun experimenting with the different commands/items. Interesting dungeon generation algorithm, too. Would be curious to see the code.

Nahjor

  • Newcomer
  • Posts: 33
  • Karma: +0/-0
    • View Profile
    • Email
Re: Mage Guild
« Reply #8 on: July 28, 2008, 07:58:10 PM »
Pretty cool little game! I haven't gotten very far, but it has been fun experimenting with the different commands/items. Interesting dungeon generation algorithm, too. Would be curious to see the code.

Thanks. :) So far, I have elected to not release source; I'm seriously considering doing so, but have yet to reach a final decision on the subject.

The dungeon gen algorithm is really pretty simple; it was mostly a matter of dinking around with odds and constants to get it to look right and fit gameplay needs. I'd be glad to expound on the details of how it works, if you're interested.

Nahjor

  • Newcomer
  • Posts: 33
  • Karma: +0/-0
    • View Profile
    • Email
Re: Mage Guild
« Reply #9 on: September 02, 2008, 04:59:33 PM »
Keeping things updated...

MageGuild is now up to 0.7.1; http://glistenimages.com/Lukos/lukosMageGuild.htm has the latest download, if anyone is interested in checking it out.

Thanks!

Vanguard

  • Rogueliker
  • ***
  • Posts: 1112
  • Karma: +0/-0
    • View Profile
Re: Mage Guild
« Reply #10 on: September 03, 2008, 03:43:33 AM »
Awesome, I'll download that asap.

Nahjor

  • Newcomer
  • Posts: 33
  • Karma: +0/-0
    • View Profile
    • Email
Re: Mage Guild
« Reply #11 on: September 04, 2008, 04:44:23 PM »
Make that 0.7.2: http://glistenimages.com/Lukos/lukosMageGuild.htm

(0.7.1 had a couple nasty crash bugs, thus the quick update)

Nahjor

  • Newcomer
  • Posts: 33
  • Karma: +0/-0
    • View Profile
    • Email
Re: Mage Guild
« Reply #12 on: September 08, 2008, 05:31:43 PM »
Heh...make that 0.7.3: http://glistenimages.com/Lukos/lukosMageGuild.htm

Same basic deal, crashes cannot be allowed to survive! Next release should be a little bit further out. :)