Author Topic: [Update] Mines of Elderlore 1.0 *beta 4* with graphics  (Read 18151 times)

Altefcat

  • Rogueliker
  • ***
  • Posts: 75
  • Karma: +0/-0
    • View Profile
    • Lands of Elderlore
[Update] Mines of Elderlore 1.0 *beta 4* with graphics
« on: March 09, 2008, 10:31:40 PM »
Here is the new release of MoE:
http://downloads.sourceforge.net/elderlore/moe10b3.source.zip
(watch out, the size of the file is about 34 Mb, sorry for short bandwidth, I'll publish a reduced release later with no music !)

Here is the changelog:
- new pygame release with graphics and music, sounds, and ambiance sounds
- if a mushroom is dropped on the player, he will grab it automatically
- weapons flavor bug corrected (first weapons found will be training ones
instead of iron ones)
- fuzzy state of axes and warhammers only hinders damage (instead of prevents
player from hitting monsters)
- monsters cannot move on player position anymore

Here are some screenshots of the graphics.
« Last Edit: March 18, 2008, 09:56:50 PM by Altefcat »

Anvilfolk

  • Rogueliker
  • ***
  • Posts: 374
  • Karma: +0/-0
    • View Profile
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #1 on: March 09, 2008, 11:44:00 PM »
I haven't played it, but the presentation is top-notch! Congratulations! It's very nice to see a graphical roguelike that ... cares about the graphics!

I don't particularly like the actual game graphics (as oposed to the GUI), but I never could get used to this kind of game representation, so I'm pretty sure it's not the tiles' fault :)
"Get it hot! Hit it harder!!!"
 - The tutor warcry

One of They Who Are Too Busy

Adral

  • Rogueliker
  • ***
  • Posts: 134
  • Karma: +0/-0
  • The Hammer of Justice
    • View Profile
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #2 on: March 10, 2008, 08:56:06 AM »
Congratulations on the new release!

Sadly, I can't play it with graphics:
Code: [Select]
[0954]adral@adral-desktop:~/sda4/Juegos/roguelikes/moe/moe$ python moe-pygame.py
New game initiated in the mines of Random...
Traceback (most recent call last):
  File "moe-pygame.py", line 741, in <module>
    update_display(s, player)
  File "moe-pygame.py", line 497, in update_display
    s.blit(map(player), (SCREEN_SIZE[0] - 256 + 16, 16))
  File "moe-pygame.py", line 294, in map
    alpha = pygame.surfarray.make_surface(tab)
ValueError: unsupported datatype for array

Do you know why this could be?

Executing $python moe.py does nothing, and executing $python moe-curses.py works.
On the wings of the storm.

Altefcat

  • Rogueliker
  • ***
  • Posts: 75
  • Karma: +0/-0
    • View Profile
    • Lands of Elderlore
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #3 on: March 10, 2008, 05:47:15 PM »
Congratulations on the new release!

Sadly, I can't play it with graphics:
Code: [Select]
[0954]adral@adral-desktop:~/sda4/Juegos/roguelikes/moe/moe$ python moe-pygame.py
New game initiated in the mines of Random...
Traceback (most recent call last):
  File "moe-pygame.py", line 741, in <module>
    update_display(s, player)
  File "moe-pygame.py", line 497, in update_display
    s.blit(map(player), (SCREEN_SIZE[0] - 256 + 16, 16))
  File "moe-pygame.py", line 294, in map
    alpha = pygame.surfarray.make_surface(tab)
ValueError: unsupported datatype for array

Do you know why this could be?

Executing $python moe.py does nothing, and executing $python moe-curses.py works.


"python moe-pygame.py" is the right command to launch it, but you need to have pygame installed. Under ubuntu, the name of the package is "python-ubuntu".

Adral

  • Rogueliker
  • ***
  • Posts: 134
  • Karma: +0/-0
  • The Hammer of Justice
    • View Profile
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #4 on: March 10, 2008, 06:18:08 PM »
I haven't found that "python-buntu" package :-/
On the wings of the storm.

Altefcat

  • Rogueliker
  • ***
  • Posts: 75
  • Karma: +0/-0
    • View Profile
    • Lands of Elderlore
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #5 on: March 10, 2008, 06:58:24 PM »
oops sorry I meant "python-pygame".

Adral

  • Rogueliker
  • ***
  • Posts: 134
  • Karma: +0/-0
  • The Hammer of Justice
    • View Profile
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #6 on: March 10, 2008, 07:35:55 PM »
I already have that installed, I think. Anyway, I get the "loading screen", but then the game shuts down and gives me that error message. I should have probably said this earlier. Sorry!

Code: [Select]
New game initiated in the mines of Random...
Traceback (most recent call last):
  File "moe-pygame.py", line 741, in <module>
    update_display(s, player)
  File "moe-pygame.py", line 497, in update_display
    s.blit(map(player), (SCREEN_SIZE[0] - 256 + 16, 16))
  File "moe-pygame.py", line 294, in map
    alpha = pygame.surfarray.make_surface(tab)
ValueError: unsupported datatype for array

On the wings of the storm.

Altefcat

  • Rogueliker
  • ***
  • Posts: 75
  • Karma: +0/-0
    • View Profile
    • Lands of Elderlore
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #7 on: March 10, 2008, 08:02:15 PM »
ok, let's try something; could you change line 294 of moe-pygame.py to this:

Code: [Select]
alpha = pygame.surfarray.make_surface(N.array(tab))
Does it solves it ?

Adral

  • Rogueliker
  • ***
  • Posts: 134
  • Karma: +0/-0
  • The Hammer of Justice
    • View Profile
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #8 on: March 10, 2008, 08:09:53 PM »
Sadly, it doesn't :(

I get this now (almost the same, only changes last line):
Code: [Select]
New game initiated in the mines of Random...
Traceback (most recent call last):
  File "moe-pygame.py", line 741, in <module>
    update_display(s, player)
  File "moe-pygame.py", line 497, in update_display
    s.blit(map(player), (SCREEN_SIZE[0] - 256 + 16, 16))
  File "moe-pygame.py", line 294, in map
    alpha = pygame.surfarray.make_surface(N.array(tab))
ValueError: unsupported datatype for array
On the wings of the storm.

Anvilfolk

  • Rogueliker
  • ***
  • Posts: 374
  • Karma: +0/-0
    • View Profile
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #9 on: March 11, 2008, 01:59:49 AM »
It might have to do with Python's version - on linux, even though you have 2.5 installed, you might still be running 2.4 when typing "python" in the console.

Check out the version! In order to update that to 2.5, I think all you have to do is replace the python softlink from 2.4 to 2.5. You can just delete the "python" file, and create a new one. Can't remember the exact syntax though.

G'luck!
"Get it hot! Hit it harder!!!"
 - The tutor warcry

One of They Who Are Too Busy

Altefcat

  • Rogueliker
  • ***
  • Posts: 75
  • Karma: +0/-0
    • View Profile
    • Lands of Elderlore
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #10 on: March 11, 2008, 08:00:21 AM »
Good idea Anvilfolk; you can launch python 2.5 with "python2.5", and 2.4 with "python2.4".

The command "whereis python" will give you all the folders where python is installed.

Adral

  • Rogueliker
  • ***
  • Posts: 134
  • Karma: +0/-0
  • The Hammer of Justice
    • View Profile
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #11 on: March 11, 2008, 02:53:57 PM »
Executing with python2.5 still gives me the same error. :(

Ah, the magnificent doom of having a 64-bit OS...
On the wings of the storm.

Altefcat

  • Rogueliker
  • ***
  • Posts: 75
  • Karma: +0/-0
    • View Profile
    • Lands of Elderlore
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #12 on: March 11, 2008, 07:27:41 PM »
I have found there a possible solution:
http://www.kibosh.org/pykaraoke/faq.php

That's a bit technical, but here is what is suggested:

Quote
AMD64/Linux Installation Issues

If you are running on the AMD64 platform (and possibly others) you may see this error on startup:

    Exception in thread Thread-1:
    #Traceback (most recent call last):
     ...
    ValueError: unsupported datatype for array

If this occurs, you need to download and install the latest development release of pygame. Follow the instructions at http://pygame.org/cvs.html to obtain the latest development release, then:

1. Build the new release by running:
    # python makeref.py
    # python setup.py install --prefix=/path/to/temporary/spot

2. Find the directory named "pygame" within /path/to/temporary/spot/lib (on a development machine, the path was lib/python2.4/site-packages/pygame) and copy or move it (all of it, including the directory itself) into the folder containing pycdg.py and the rest of the PyKaraoke files.

Altefcat

  • Rogueliker
  • ***
  • Posts: 75
  • Karma: +0/-0
    • View Profile
    • Lands of Elderlore
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #13 on: March 11, 2008, 07:41:48 PM »
Update : you can get this debian package that I think should solve your problem:
http://packages.debian.org/etch/amd64/python-pygame/download

This bug is indeed related to 64 bit OSes, and has been corrected in pygame cvs during year 2005:
http://archives.seul.org/pygame/users/Oct-2005/msg00135.html

Please let me know if it solves your problem ! (crosses fingers...)

Anvilfolk

  • Rogueliker
  • ***
  • Posts: 374
  • Karma: +0/-0
    • View Profile
Re: Mines of Elderlore 1.0 beta 3 with graphics
« Reply #14 on: March 11, 2008, 07:43:12 PM »
Off-topic: if it was corrected in 2005, and now it's 2008, why the heck hasn't it made into the actual distribution?
"Get it hot! Hit it harder!!!"
 - The tutor warcry

One of They Who Are Too Busy