Author Topic: Legacy code problems  (Read 4178 times)

Krice

  • (Banned)
  • Rogueliker
  • ***
  • Posts: 2316
  • Karma: +0/-2
    • View Profile
    • Email
Legacy code problems
« on: September 19, 2010, 11:35:42 AM »
I'm trying to compile my legacy code (Kaduria) with new Code::Blocks that has newest (I guess) gcc included. This gives an error:

for (list<T>::iterator pos=v.begin(); pos!=v.end(); pos++)

Error: expected ; before pos.

What the hell?

Edit: solved, needed to add typename in front of list.
« Last Edit: September 19, 2010, 11:40:19 AM by Krice »

RoguelikeGCS

  • Newcomer
  • Posts: 16
  • Karma: +0/-0
    • View Profile
    • Roguelike GCS
Re: Legacy code problems
« Reply #1 on: September 19, 2010, 07:30:25 PM »