Author Topic: ToME 2 mods  (Read 15786 times)

Shin Majin

  • Newcomer
  • Posts: 19
  • Karma: +0/-0
    • View Profile
    • Email
ToME 2 mods
« on: July 23, 2012, 11:41:57 PM »
I recall that back when ToME 2.x actually had a site, there was a section for various mods for the game, including a Narnia-themed one.  Does anybody here know if these mods are still available, and if so, where?

Ancient

  • Rogueliker
  • ***
  • Posts: 453
  • Karma: +0/-0
    • View Profile
Re: ToME 2 mods
« Reply #1 on: July 28, 2012, 08:32:14 AM »
Ah, another opportunity to use my precious wand of wishing. *KZAPP*

Part of them are accessible through Wayback Machine.
The mod list itself: http://web.archive.org/web/20071230084314/http://modules.t-o-m-e.net/list.php
Actually crawled modules: http://wayback.archive.org/web/*/http://modules.t-o-m-e.net/mods/*

Then guys at rlgclub have a lot of them stashed here: http://zip.rlgclub.ru/lib.php?d=ToME%202%20Mods&s=n&o=asc
Unfortunately in some cases archived stuff is not the latest version released.
Michał Bieliński, reviewer for Temple of the Roguelike

Shin Majin

  • Newcomer
  • Posts: 19
  • Karma: +0/-0
    • View Profile
    • Email
Re: ToME 2 mods
« Reply #2 on: July 30, 2012, 04:15:30 AM »
Many thanks!  I'd just figured that they were gone!

EDIT: Erh...none of the download links work!

Er...rather, none of the mods will work.  What version of ToME were they supposed to go with?
« Last Edit: July 30, 2012, 04:56:14 PM by Shin Majin »

Ancient

  • Rogueliker
  • ***
  • Posts: 453
  • Karma: +0/-0
    • View Profile
Re: ToME 2 mods
« Reply #3 on: August 03, 2012, 06:06:50 AM »
ToME 2.3.5. Was the last of 2.0 branch. What version did you try them with?

E: It appears you can find 2.3.5 here: http://zip.rlgclub.ru/lib.php?d=ToME&s=n&o=asc
« Last Edit: August 03, 2012, 06:13:10 AM by Ancient »
Michał Bieliński, reviewer for Temple of the Roguelike

Shin Majin

  • Newcomer
  • Posts: 19
  • Karma: +0/-0
    • View Profile
    • Email
Re: ToME 2 mods
« Reply #4 on: August 03, 2012, 05:57:44 PM »
I tried them on 2.3.5, but they didn't work.  I heard on the ToME forums that 2.3.5 has a bug that prevents mods from working.  Can anybody confirm/deny this?  Is the problem in ToME, or all those mods?

Ancient

  • Rogueliker
  • ***
  • Posts: 453
  • Karma: +0/-0
    • View Profile
Re: ToME 2 mods
« Reply #5 on: August 04, 2012, 10:26:14 AM »
I downloaded sources of 2.3.4, compiled them. Went smoothly. Next I took Narnia Tome and unpacked it into its own directory within lib/mods. This is important. The archives do not come with their base parent directory but they should. Maybe 2.3.5 has this bug you speak about but I am too lazy to check. If you do I would appreciate information on this topic.

For each module you get put it there

ToME 2/lib/mods/DIRECTORY/

where DIRECTORY is any name you think up.

White Witch Castle seems to be good place to start looking for trouble.
Michał Bieliński, reviewer for Temple of the Roguelike

Shin Majin

  • Newcomer
  • Posts: 19
  • Karma: +0/-0
    • View Profile
    • Email
Re: ToME 2 mods
« Reply #6 on: August 08, 2012, 03:13:02 PM »
Is the problem that I didn't compile it from source?  I'm not very knowledgeable about compiling, and haven't the slightest clue how to compile ToME.  (Only RL I've ever compiled reliably is Cataclysm.)

Aha!  The solution...was to rename the directories!

"Tome 2 Mod - Zodiac {1.3.0}" does not work, but "Zodiac" does!  Well, for several of them.  Others still just don't work.
« Last Edit: August 08, 2012, 03:22:33 PM by Shin Majin »

Ancient

  • Rogueliker
  • ***
  • Posts: 453
  • Karma: +0/-0
    • View Profile
Re: ToME 2 mods
« Reply #7 on: August 08, 2012, 05:43:12 PM »
Make sure the directory name is no longer than eight characters. It should contain only latin characters and digits. Underscore is valid too. Probably DOS legacy is creeping in.
Michał Bieliński, reviewer for Temple of the Roguelike

darwin

  • Newcomer
  • Posts: 4
  • Karma: +0/-0
    • ICQ Messenger - 14691052
    • View Profile
    • David Chmelik homesite
    • Email
Re: ToME 2 mods
« Reply #8 on: October 20, 2023, 03:36:40 AM »
ArchiveRL has many modules including the Narnia one which I want to play.  I unarchived for tome 2.3.5 as lib/mods/Narnia but it wasn't detected, and tome 2.3.4 no longer compiles on my current PC.