Author Topic: Images not appearing on my site!  (Read 113 times)

breckjensen

  • Guest
Images not appearing on my site!
« on: September 19, 2017, 10:32:43 AM »
Hey. I've uploaded my site, with webs.com as the host, but the header and footer are displayed as "Oops! Image Not Found!" banners, the pictures are all JPEG images.
I love web designing and have spent so long creating the site that I'm really frustrated now. I have uploaded the index.html and the style.css yet I can't see the images!
I'm a noob and I know I've probably made some stupid mistake, so I'd really appreciate someone being able to help
Please Help !
Thanks !
I didn't find the right solution from the internet.
References:
- http://www.computerforums.org/forums/web-programming/images-not-appearing-my-site-298764502939.html
- whiteboard video

sokol815

  • Priest
  • **
  • Posts: 84
  • Web Developer by Day, still Web Developer by night
    • View Profile
    • My Projects
    • Email
Re: Images not appearing on my site!
« Reply #1 on: September 20, 2017, 09:39:02 PM »
Sounds like the urls you're referencing for your images are incorrect. The easiest way to get it correct is to create an images folder in the same folder as your index.html file. Then put all the images in there. Now, in your index.html, anytime you want to reference an image, just set the src to something like <img src="images/imageName.jpg" />. When the browser sees a "relative" source like this, it knows that the image you're looking for is in a folder inside your current location. The other option is to statically reference all of your images... you could put a folder called "images" in the web-root of your website and now anytime you want to reference an image on your website, just use <img src="/images/imageName.jpg" />.

Here's a helpful reference.
« Last Edit: September 20, 2017, 09:41:03 PM by sokol815 »
My projects - http://exilania.com/landing/   |  Minotaur vs orcs -  http://exilania.com/minotaur/ |  Strife  -  http://exilania.com/strife/

Tzan

  • Bishop
  • ***
  • Posts: 134
    • View Profile
Re: Images not appearing on my site!
« Reply #2 on: September 21, 2017, 04:55:44 PM »
Its a spammer.
Look at the second link, don't click on it.