Author Topic: Hacklite?  (Read 711 times)

Legend

  • Protector of the @
  • *****
  • Posts: 629
    • View Profile
    • Email
Hacklite?
« on: November 14, 2015, 08:48:57 PM »
I've been delving into some older roguelikes lately and wanted to give hacklite a try.

Unfortunately, I cannot get it to work for the life of me.

I'm using the version found here: http://www.roguelikedevelopment.org/archive/

At first I couldn't get it to open at all. Then i tried messing with the config file and got it to start, but it just comes out an unplayable jumbled mess.

Anyone get it to work?  I'm using win xp btw.

akeley

  • High Priest
  • ****
  • Posts: 330
    • View Profile
Re: Hacklite?
« Reply #1 on: November 14, 2015, 11:39:43 PM »
Quote
If when you try to play Hack Lite, instead of a dungeon map you get a screen
full of weird characters, your problem is probably the lack of ANSI.SYS.

Not sure if you saw this in README. However, it runs okay for me (also XP SP3) when using D-Fend Reloaded, a DosBox frontend.

I didn`t have to mess with CONFIG.SYS like the readme says, just chose the HDD configuration in Hacklite.cnf, adjusted the paths accordingly and it works.

(Which is as well, I can not stand a DOS game not working and would probably stay up late fighting this :P)




Legend

  • Protector of the @
  • *****
  • Posts: 629
    • View Profile
    • Email
Re: Hacklite?
« Reply #2 on: November 15, 2015, 12:30:48 AM »
Quote
If when you try to play Hack Lite, instead of a dungeon map you get a screen
full of weird characters, your problem is probably the lack of ANSI.SYS.

Not sure if you saw this in README. However, it runs okay for me (also XP SP3) when using D-Fend Reloaded, a DosBox frontend.

I didn`t have to mess with CONFIG.SYS like the readme says, just chose the HDD configuration in Hacklite.cnf, adjusted the paths accordingly and it works.

(Which is as well, I can not stand a DOS game not working and would probably stay up late fighting this :P)

No, I didn't see that. Thanks for pointing that out. I did change the hdd paths though.

I wasn't using dosbox either. Was hoping it would run as easy as larn and umoria out of the box.  I only have dosbox as part of some gog packages. Don't have it actually installed on my computer since I don't really have anything I need it for. (other than hacklite now obviously).  :p

Think you could post a copy of your config file?

I can't seem to get the hacklite.cnf configed right.

I keep getting a "bad option line" error on all the path names.

EDIT:  after doing some searching, I found this:  http://www.robvanderwoude.com/ansi.php#AnsiCom

Now I'm determined to see if I can figure out how to use the ansi.com file to make a batch file that will run hacklite without having to mess with my config.sys file. Gotta figure out how to make a proper batch file first of course though.   :p
« Last Edit: November 15, 2015, 01:02:19 AM by Legend »

akeley

  • High Priest
  • ****
  • Posts: 330
    • View Profile
Re: Hacklite?
« Reply #3 on: November 15, 2015, 12:39:53 PM »
I didn`t really alter the .cnf apart from removing the # (and also the couple of SPACEs - it didn`t work otherwise) next to HDD section. So it looks like this:

Code: [Select]
OPTIONS=name:Hacker,rest_on_space,IBMBIOS,rawio,color
SAVE=c:\hack\game;n
LEVELS=c:\hack\game
RAMDISK=d:
HACKDIR=c:\hack\game

Then named my game dir like above - hack\game - and set up D-Fend paths accordingly.

Maybe just try that original config and make hack\game dir in your C: drive with the .exe and everything. The access should work then. If the display`s garbled, try adding that ANSI line from readme into CONFIG.SYS.

Last resort, try pure DosBox or D-Fend (easier to set up)...I suppose these take care of ANSI automatically.